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Rozdział 1

Wprowadzenie do programu KiCad

KiCad EDA Suite to oprogramowanie narzędziowe przeznaczone do tworzenia schematów elektronicznych oraz ob-
wodów drukowanych PCB. Pod jednym prostym interfejsem KiCad łączy elegancki zespół następujących, samodziel-
nych programów:

Nazwa programu Opis Rozszerzenia plików
KiCad Menadżer projektu *.pro
Eeschema Edytor Schematów (zarówno

schematów jak i symboli)
*.sch, *.lib, *.net

Pcbnew Edytor Obwodów Drukowanych *.kicad_pcb, *.kicad_mod
GerbView Przeglądarka plików Gerber i

Excellon
*.g\*, *.drl, itp.

Bitmap2Component Narzędzie do konwersji bitmap na
symbole lub footprinty

*.lib, *.kicad_mod, *.
kicad_wks

PCB Calculator Wszechstronny kalkulator do
obliczania komponentów,
szerokości ścieżek, odległości
między ścieżkami i wiele innych…

Brak

Pl Editor Edytor Układu Strony *.kicad_wks

Notatka
Lista rozszerzeń plików nie jest kompletna i zawiera tylko podzbiór plików, które wspiera program KiCad. Są one pomocne
do zrozumienia podstaw działania każdej aplikacji wchodzącej w skład pakietu KiCad EDA Suite.

KiCad można uznać za wystarczająco dojrzałe oprogramowanie, by wykorzystać go do tworzenia i utrzymywania
złożonych projektów obwodów drukowanych.

KiCad nie stwarza żadnego ograniczenia co do rozmiaru PCB i może z łatwością obsługiwać do 32 warstw miedzi,
do 14 warstw technicznych oraz do 4 warstw pomocniczych. KiCad może tworzyć też wszystkie pliki niezbędne do
tworzenia obwodów drukowanych: pliki Gerber dla foto-ploterów, pliki wierceń, pliki z lokalizacją elementów i wiele
więcej.
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Będąc oprogramowaniem otwartym (na licencji GPL), KiCad stanowi idealne narzędzie dla projektów zorientowanych
w kierunku urządzeń o charakterze Open-Source.

W sieci Internet strona domowa programu KiCad znajduje się pod tym adresem:

http://www.kicad-pcb.org/

1.1 Pobieranie i instalowanie programu KiCad

KiCad runs on GNU/Linux, Apple macOS and Windows. You can find the most up to date instructions and download
links at:

http://www.kicad-pcb.org/download/

WAŻNE
Edycje stabilne programu KiCad są publikowane co jakiś czas zgodnie z polityką wydawniczą: KiCad Stable Re-
lease Policy. Nowe funkcje są ciągle dodawane do gałęzi rozwojowej. Jeśli użytkownik chce skorzystać z tych
nowych funkcji i pomóc przy ich testowaniu, należy pobrać najnowszy pakiet edycji testowej Nightly przewidziany
dla używanej platformy. Edycje testowe mogą wprowadzać błędy, takie jak uszkodzenie plików, generowanie
niepoprawnych plików Gerber, itp.; ale celem Zespołu Rozwojowego programu KiCad jest utrzymać gałąź rozwo-
jową tak użyteczną, jak to tylko możliwe w trakcie rozwijania nowych funkcji.

1.1.1 W systemie GNU/Linux

Stabilne wydania programu KiCad można znaleźć w menadżerach pakietów wielu dystrybucji jako kicad i kicad-doc.
Jeśli używana dystrybucja nie dostarcza najnowszej wersji stabilnej, proszę skorzystać z instrukcji poniżej w celu
pozyskania jednej z wersji testowych.

W systemie Ubuntu, najprostszą metodą instalacji wersji testowych programu KiCad (Nightly) jest skorzystanie z
PPA oraz Aptitude. Wpisz w konsoli następujące polecenia:

sudo add-apt-repository ppa:js-reynaud/ppa-kicad

sudo aptitude update && sudo aptitude safe-upgrade

sudo aptitude install kicad kicad-doc-en

W systemach opartych na dystrybucji Fedora najprosztszą metodą instalacji wersji testowych jest użycie copr. By
zainstalować program KiCad za pomocą copr należy wydać następujące polecenia:

sudo dnf copr enable mangelajo/kicad

sudo dnf install kicad

Alternatywnie, możesz pobrać i zainstalować wersję pre-kompilowaną KiCad-a lub bezpośrednio pobrać kod źródłowy,
skompilować go oraz zainstalować z niego KiCad-a.

http://www.kicad-pcb.org/
http://www.kicad-pcb.org/download/
http://ci.kicad-pcb.org/job/kicad-doxygen/ws/Documentation/doxygen/html/md_Documentation_development_stable-release-policy.html
http://ci.kicad-pcb.org/job/kicad-doxygen/ws/Documentation/doxygen/html/md_Documentation_development_stable-release-policy.html
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1.1.2 Under Apple macOS

Stable builds of KiCad for macOS can be found at: http://downloads.kicad-pcb.org/osx/stable/

Wersje testowe można znaleźć pod adresem: http://downloads.kicad-pcb.org/osx/

1.1.3 W systemie Windows

Wersje stabilne programu KiCad dla systemu Windows można znaleźć pod adresem: http://downloads.kicad-pcb.org/-
windows/stable/

Dla systemuWindows można skorzystać z wersji testowych dostępnych pod adresem: http://downloads.kicad-pcb.org/-
windows/

1.2 Wsparcie

Jeśli masz pomysł, chciałbyś skomentować lub zadać pytanie, albo po prostu potrzebujesz pomocy:

• Odwiedź forum

• Dołącz do kanał IRC #kicad na Freenode

• Przejrzyj samouczki

http://downloads.kicad-pcb.org/osx/stable/
http://downloads.kicad-pcb.org/osx/
http://downloads.kicad-pcb.org/windows/stable/
http://downloads.kicad-pcb.org/windows/stable/
http://downloads.kicad-pcb.org/windows/
http://downloads.kicad-pcb.org/windows/
https://forum.kicad.info/
http://webchat.freenode.net/?channels=kicad
http://www.kicad-pcb.org/help/tutorials/
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Rozdział 2

Schemat postępowania

Pomimo podobieństw do innego oprogramowania narzędziowego do tworzenia PCB, KiCad charakteryzuje się unikalnym
schematem postępowania, w którym komponenty na schemacie i footprinty są niezależne. Po narysowaniu schematu
należy należy przypisać footprinty poszczególnym komponentom.

2.1 Przegląd

Cykl postępowania w przypadku programu KiCad składa się z dwóch głównych zadań: tworzenie schematu i trasowanie
płytki. Obie biblioteki: komponentów oraz footprintów są niezbędne dla obu tych zadań. KiCad posiada sporo
komponentów oraz footprintów, a także oferuje narzędzia niezbędne do tworzenia nowych.

Na rysunku poniżej można zobaczyć schemat postępowania reprezentujący proces tworzenia kompletnego projektu w
programie KiCad. Rysunek wyjaśnia jakie kroki należy podjąć i w jakiej kolejności należy je wykonać. Dodatkowe
ikony ukazują narzędzia jakich należy użyć.
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For more information about creating a component, read Making schematic symbols. And for information about how
to create a new footprint, see Making component footprints.

Quicklib to narzędzie on-line, które pozwali szybko tworzyć biblioteki komponentów dla programu KiCad. Aby uzyskać
więcej informacji na temat Quicklib, przejdź do sekcji nazwanej: Tworzenie symboli za pomocą Quicklib.

2.2 Renumeracja elementów oraz numeracja wsteczna

Gdy schemat został już w pełni opracowany, następnym krokiem jest przeniesienie go do PCB. Często zdarza się, że
trzeba dodać do projektu dodatkowe komponenty lub zmiany w istniejących, zmienić nazwy sieci, itp. Można to zrobić
na dwa sposoby: z wykorzystaniem narzędzi do renumeracji elementów lub numeracji wstecznej.

Renumeracja elementów to proces przesyłania zmian w schemacie do odpowiadającego mu obwdu PCB. Jest to funda-
mentalna funkcja, ponieważ należy ją wykonać przynajmniej raz by zaimportować dane ze schematu na PCB. Później,
proces renumeracji pozwala na przesłanie ewentualnych zmian w schemacie tak, by PCB było zgodne ze schematem.
Renumeracja elementów została omówiona w rozdziale zatytułowanym Renumeracja elementów w programie KiCad.

Numeracja wsteczna to proces przesyłania dokonanych zmian na PCB z powrotem do schematu. Zwykle takie działanie
jest powodowane przez zamianę pinów lub zamianę części składowych. W takich sytuacjach istniejące bramki lub piny
- które są funkcjonalnie równoważne - są zamieniane między sobą by uprościć prowadzenie niektórych ścieżek. Dlatego,
taka zmiana dokonana w PCB musi zostać później odzwierciedlona na schemacie.

http://kicad.rohrbacher.net/quicklib.php
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Rozdział 3

Używanie programu KiCad

3.1 Skróty klawiszowe

KiCad posiada dwa rodzaje podobnych choć różnych skrótów klawiszowych: klawisze akceleracji oraz hotkeys. Oba są
używane do przyśpieszania pracy w programie KiCad przy użyciu klawiatury zamiast myszy do zmiany lub wydawania
poleceń.

3.1.1 Klawisze akceleracji

Klawisze akceleracji mają taki sam efekt jak kliknięcie na menu lub ikonę na pasku narzędzi: polecenie zostanie
wprowadzone, ale nic się nie stanie, do czasu gdy lewy przycisk myszy nie zostanie kliknięty. Zatem, gdy chcemy
wprowadzić się w tryb poleceń ale nie żądamy natychmiastowego działania, należy użyć klawisza akceleracji.

Klawisze akceleracji są pokazywane na prawo od poszczególnych pozycji menu:

3.1.2 Hotkeys

Hotkey jest tożsamy klawiszowi akceleracji plus kliknięcie lewym klawiszem myszy. Używając takiego skrótu natych-
miast uruchamia się dane polecenie w miejscu bieżącego położenia kursora. Użycie hotkeys pozwala szybko zmienić
polecenie bez przerywania pracy.
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To view hotkeys within any KiCad tool go to Help → List Hotkeys or press Ctrl+F1:

You can edit the assignment of hotkeys, and import or export them, from the Preferences → Hotkeys Options
menu.

Notatka
W tym dokumencie przyjęto konwencję, że klawisze hotkeys są zamknięte w nawiasy kwadratowe: [a]. Jeśli wystąpi taki
zapis, należy wtedy nacisnąć klawisz ↪ańa klawiaturze.

3.1.3 Przykład

Rozważmy prosty przykład z dodawaniem połączenia na schemacie.

By użyć klawisza akceleracji, naciśnij Śhift + W”by wywołać polecenie ”Dodaj połączenie”(zauważ, jak zmieni się
kursor). Następnie, kliknij lewym klawiszem myszy by rozpocząć prowadzenie połączenia.

Za pomocą klawiszy hotkey, po prostu wciśnij [w] by rysowanie połączenia zostało zapoczątkowane bezzwłocznie z
bieżacej lokacji kursora.
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Rozdział 4

Rysowanie schematów

W tej sekcji nauczymy się rysować schematy za pomocą narzędzi zawartych w KiCad EDA.

4.1 Używanie Eeschema

1. W systemie Windows uruchom kicad.exe. W systemie Linux wpisz kicad w oknie konsoli. Znajdziesz się wt-
edy w głównym oknie zarządcy projektu programu KiCad. Z tego miejsca masz dostęp do ośmiu samodzielnych
narzędzi: Eeschema, Edytor bibliotek symboli, Pcbnew, Edytor bibliotek footprintów, GerbView, Bitmap2Component,
PCB Calculator oraz Pl_Editor. Spójrz na cykl postępowania by rozeznać się do czego poszczególne narzędzia
są używane.
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2. Create a new project: File → New → Project. Name the project file tutorial1. The project file will automat-
ically take the extension ”.pro”. The exact appearance of the dialog depends on the used platform, but there
should be a checkbox for creating a new directory. Let it stay checked unless you already have a dedicated
directory. All your project files will be saved there.

3. Rozpocznijmy od utworzenia schematu. Uruchom program do edycji schematów Eeschema, . Jest to
pierwszy klawisz licząc od lewej.

4. Click on the Page Settings icon on the top toolbar. Set the appropriate paper size (A4,8.5x11 etc.) and
enter the Title as Tutorial1. You will see that more information can be entered here if necessary. Click OK.
This information will populate the schematic sheet at the bottom right corner. Use the mouse wheel to zoom
in. Save the whole schematic: File → Save

5. We will now place our first component. Click on the Place symbol icon in the right toolbar. You may also
press the Add Symbol hotkey [a].

6. Click on the middle of your schematic sheet. A Choose Symbol window will appear on the screen. We’re going
to place a resistor. Search / filter on the R of Resistor. You may notice the Device heading above the Resistor.
This Device heading is the name of the library where the component is located, which is quite a generic and
useful library.
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7. Double click on it. This will close the Choose Symbol window. Place the component in the schematic sheet by
clicking where you want it to be.

8. Kliknij na lupę by powiększyć widoczny obszar wokół tego komponentu. Alternatywnie, możesz użyć kółka
myszy by powiększyć lub pomniejszyć widoczny obszar. Wciśnij kółko (klaiwsz centralny) by wywołać funkcję
panoramowania w pionie lub poziomie.

9. Przesuń kursor myszy nad komponent R oraz naciśnij klawisz [r]. Zauważ, w jaki sposób komponent został
obrócony. Nie musisz klikać na komponent by móc go obrócić.

Notatka
If your mouse was also over the Field Reference (R) or the Field Value (R?), a menu will appear. You will see the
Clarify Selection menu often in KiCad; it allows working on objects that are on top of each other. In this case, tell
KiCad you want to perform the action on the Symbol …R….

10. Right click in the middle of the component and select Properties → Edit Value. You can achieve the same
result by hovering over the component and pressing [v]. Alternatively, [e] will take you to the more general
Properties window. Notice how the right-click menu below shows the hotkeys for all available actions.
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11. The Edit Value Field window will appear. Replace the current value R with 1 k. Click OK.

Notatka
Nie zmieniaj pola Odniesienie (R?), zrobimy to później z pomocą automatu. Wartość wewnątrz rezystora od teraz
powinna wynosić 1k.

12. To place another resistor, simply click where you want the resistor to appear. The symbol selection window will
appear again.
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13. Rezystor jaki wybrałeś poprzednim razem teraz jest już na twojej liście z historią wyboru jako R. Kliknij OK i
umieść komponent.

14. In case you make a mistake and want to delete a component, right click on the component and click Delete. This
will remove the component from the schematic. Alternatively, you can hover over the component you want to
delete and press [Delete].

15. Możesz również powielić komponent znajdujący się już na twoim arkuszu, przez najechanie na niego kursorem i
wciskając klawisz [c]. Kliknij teraz gdzie chciałbyś umieścić nowy, zduplikowany komponent.

16. Right click on the second resistor. Select Drag. Reposition the component and left click to drop. The same
functionality can be achieved by hovering over the component and by pressing [g]. [r] will rotate the component
while [x] and [y] will flip it about its x- or y-axis.

Notatka
Right-Click → Move or [m] is also a valuable option for moving anything around, but it is better to use this only
for component labels and components yet to be connected. We will see later on why this is the case.
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17. Dokonaj edycji drugiego rezystora najeżdżając na niego i wciskając klawisz [v]. Zamień R na 100. Możesz usunąć
dowolną edycję jaką wykonałeś za pomocą klawisza [Ctrl]+[z].

18. Change the grid size. You have probably noticed that on the schematic sheet all components are snapped
onto a large pitch grid. You can easily change the size of the grid by Right-Click → Grid. In general, it is
recommended to use a grid of 50.0 mils for the schematic sheet.

19. We are going to add a component from a library that isn’t configured in the default project. In the menu,
choose Preferences → Manage Symbol Libraries. In the Symbol Libraries window you can see two tabs:
Global Libraries and Project Specific Libraries. Each one has one sym-lib-table file. For a library (.lib file) to
be available it must be in one of those sym-lib-table files. If you have a library file in your file system and it’s
not yet available, you can add it to either one of the sym-lib-table files with Browse Libraries. For practise
we will now add a library which already is available.

20. You need to find where the official KiCad libraries are installed on your computer. Look for a library di-
rectory containing a hundred of .dcm and .lib files. Try in C:\Program Files (x86)\KiCad\share\ (Win-
dows) and /usr/share/kicad/library/ (Linux). When you have found the directory, choose and add the
MCU_Microchip_PIC12.lib library and close the window. You will get a warning that the name already exists
in the list; add it anyways. It will be added to the end of of the list. Now click its nickname and change it to
microchip_pic12mcu. Close the Symbol Libraries window with OK.

21. Repeat the add-component steps, however this time select the microchip_pic12mcu library instead of the Device
library and pick the PIC12C508A-ISN component.

22. Najedź myszą na mikrokontroler. Naciśnij klawisz [y] lub klawisz [x] na klawiaturze. Zauważ w jaki sposób
komponent zostaje przerzucany w osi X lub osi Y. Naciskaj klawisze ponownie by wrócić do jego oryginalnego
położenia.

23. Repeat the add-component steps, this time choosing the Device library and picking the LED component from
it.

24. Ułóż komponenty na twoim schemacie tak jak pokazano poniżej.
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25. W tej chwili musimy stworzyć nowy komponentMYCONN3 dla naszego trójpinowego złącza. Możesz przeskoczyć
do rozdziału zatytułowanego Tworzenie symboli w programie KiCad by nauczyć się jak utworzyć ten komponent
od zera i wrócić tu by kontynuować tworzenie płytki.

26. W tej chwili możesz już wstawić świeżo utworzony komponent. Naciśnij klawisz [a] i wybierz MYCONN3 w
bibliotece myLib.

27. Identyfikator komponentu J? pojawi się pod symbolem MYCONN3. Jeśli chcesz zmienić jego położenie, kliknij
prawym klawiszem na J? oraz kliknij w Przesuń pole (odpowiednik klawisza [m]). Może być również pomocne
przybliżenie widoku przed/podczas wykonywania tego kroku. Zmień położenie J? tak by tekst znalazł się pod
komponentem tak jak na obrazku. Etykiety mogą być przesuwane wokół, tyle razy ile zechcesz.
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28. It is time to place the power and ground symbols. Click on the Place power port button on the right
toolbar. Alternatively, press [p]. In the component selection window, scroll down and select VCC from the
power library. Click OK.

29. Kliknij w okolicy górnego pinu rezystora 1k by umieścić tam element VCC. Kliknij w okolicy wyprowadzenia VDD
mikrokontrolera. W polu Ostatnio użyte elementy wybierz VCC i umieść go w okolicy wyprowadzenia VDD.
Powtórz ten proces ponownie i wstaw element VCC powyżej wyprowadzenia VCC komponentu MYCONN3.

30. Repeat the add-pin steps but this time select the GND part. Place a GND part under the GND pin ofMYCONN3.
Place another GND symbol on the left of the VSS pin of the microcontroller. Your schematic should now look
something like this:

31. Następnym krokiem będzie łączenie naszych komponentów. Kliknij na ikonę Dodaj połączenie na prawym
panelu.

Notatka
Be careful not to pick Place bus, which appears directly beneath this button but has thicker lines. The section Bus
Connections in KiCad will explain how to use a bus section.
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32. Click on the little circle at the end of pin 7 of the microcontroller and then click on the little circle on pin 1 of
the LED. You can zoom in while you are placing the connection.

Notatka
Jeśli chcesz przesunąć połączone elementy, ważne jest by do tego celu użyć klawisza [g] (przeciągnij) a nie klawisza
[m] (przesuń). Użycie opcji Przeciągnij symbol zachowa połączenia przesuwanego elementu. Jeśli zapomniałeś już
jak przesuwać elementy spójrz jeszcze raz na krok numer 24.

33. Powtórz ten proces oraz połącz wszystkie inne komponenty tak jak pokazano poniżej. By przerwać łączenie po
prostu kliknij dwukrotnie. Gdy łączysz symbole VCC i GND, połączenie powinno dotknąć dolnej części symbolu
VCC oraz środka na górze w symbolu GND. Zobacz poniższy obrazek.
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34. We will now consider an alternative way of making a connection using labels. Pick a net labelling tool by clicking

on the Place net label icon on the right toolbar. You can also use [l].

35. Kliknij w środku połączenia biegnącego z wyprowadzenia numer 6 mikrokontrolera. Nazwij tą etykietę INPUT.

36. Postępuj zgodnie z tą procedurą oraz wstaw inną etykietę na linii na prawo od rezystora 100R. Nazwij ją również
INPUT. Dwie etykiety, posiadające taką samą nazwę, tworzą niewidoczne połączenie pomiędzy wyprowadzeniem
numer 6 procesora PIC a rezystorem 100R. Jest to wygodna technika łączenia w skomplikowanych projektach,
gdzie rysowanie połączeń jako oddzielnych linii spowodowałoby, że schemat stałby się nieczytelny. By wstawić
etykietę nie potrzebujesz rysować części połączenia, możesz po prostu dopiąć etykietę do wyprowadzenia.

37. Etykiety mogą być także użyte do prostego oznaczania połączeń w celach informacyjnych. Umieść etykietę na
wyprowadzeniu numer 7 procesora PIC. Wpisz nazwę uCtoLED. Nazwij połączenie pomiędzy rezystorem a diodą
LED jako LEDtoR. Nazwij połączenie pomiędzy MYCONN3 a rezystorem jako INPUTtoR.

38. Nie musisz dodawać etykiet do sieci VCC oraz GND, ponieważ ich etykiety są tworzone domyślnie z nazw portów
zasilania, do których są one połączone.

39. Poniżej możesz zobaczyć jak powinien wyglądać końcowy rezultat.
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40. Zajmijmy się teraz wyprowadzeniami niepołączonymi. Każde z wyprowadzeń albo połączeń, które nie są z
niczym połączone, generuje ostrzeżenie podczas testu poprawności projektu. By zapobiec tym ostrzeżeniom
możesz poinstruować program, że jest to celowe działanie i oflagować te elementy jako niepołączone.

41. Click on the Place no connection flag icon on the right toolbar. Click on pins 2, 3, 4 and 5. An X will
appear to signify that the lack of a wire connection is intentional.
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42. Niektóre z komponentów mają wyprowadzenia zasilania, które są niewidoczne. Możesz sprawić by były widoczne

klikając na ikonę Pokaż ukryte piny na lewym pasku narzędzi. Ukryte piny zasilania zostają automatycznie
połączone do właściwych sieci VCC oraz GND. Mówiąc ogólnie, powinieneś również spróbować nie tworzyć
ukrytych wyprowadzeń zasilania.

43. It is now necessary to add a Power Flag to indicate to KiCad that power comes in from somewhere. Press [a]
and search for PWR_FLAG which is in power library. Place two of them. Connect them to a GND pin and to
VCC as shown below.

Notatka
Pozwoli to na uniknięcie klasycznego ostrzeżenia przy sprawdzaniu schematu: Ostrzeżenie Wyprowadzenie
power_in nie jest sterowany (Sieć xx)

44. Sometimes it is good to write comments here and there. To add comments on the schematic use the Place text

icon on the right toolbar.

45. All components now need to have unique identifiers. In fact, many of our components are still named R? or J?.

Identifier assignation can be done automatically by clicking on the Annotate schematic symbols icon on the
top toolbar.

46. In the Annotate Schematic window, select Use the entire schematic and click on the Annotate button. Click OK
in the confirmation message and then click Close. Notice how all the ? have been replaced with numbers. Each
identifier is now unique. In our example, they have been named R1, R2, U1, D1 and J1.

47. Możemy teraz sprawdzić nasz schemat czy nie ma w nim podstawowych błędów. Kliknij w ikonę Kontrola

reguł projektowych . Następnie kliknij na przycisk Uruchom. Raport poinformuje cię o wszystkich błędach
lub ostrzeżeniach, takich jak na przykład niepołączone wyprowadzenia. Powinieneś nie mieć żadnych błędów
lub ostrzeżeń. W przypadku błędów lub ostrzeżeń, na schemacie pojawia się mała zielona strzałka w miejscu
gdzie został wykryty błąd lub ostrzeżenie. Zaznacz Utwórz plik raportu i wciśnij klawisz Uruchom ponownie by
otrzymać więcej informacji o błędach.

Notatka
If you have a warning with Ńo default editor found, you must choose it”, try setting the path to c:\windows\
notepad.exe (windows) or /usr/bin/gedit (Linux).
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48. The schematic is now finished. We can now create a Netlist file to which we will add the footprint of each

component. Click on the Generate netlist icon on the top toolbar. Click on the Generate Netlist button
and save under the default file name.

49. Po wygenerowaniu listy sieci, kliknij na ikonę Uruchom CvPcb na górnym panelu. Jeśli otrzymasz informację
o nieistniejącym pliku, zignoruj ją i kliknij na OK.

50. Cvpcb allows you to link all the components in your schematic with footprints in the KiCad library. The pane
on the center shows all the components used in your schematic. Here select D1. In the pane on the right you
have all the available footprints, here scroll down to LED_THT:LED-D5.0mm and double click on it.

51. Możliwe jest, że panel na prawej stronie będzie wyświetlał tylko pewną podgrupę dostępnych modułów. Jest to
spowodowane tym, że KiCad będzie się starał podpowiedzieć jakie moduły są właściwe dla danego komponentu.

Kliknij na ikony , oraz by wyłączyć te filtry.

52. For U1 select the Package_DIP:DIP-8_W7.62mm footprint. For J1 select the Connector:Banana_Jack_3Pin
footprint. For R1 and R2 select the Resistor_THT:R_Axial_DIN0207_L6.3mm_D2.5mm_P2.54mm_Vertical
footprint.

53. If you are interested in knowing what the footprint you are choosing looks like, you can click on the View selected

footprint icon for a preview of the current footprint.

54. You are done. You can save the schematic now by clicking File → Save Schematic or with the button Apply,
Save Schematic & Continue.

55. You can close Cvpcb and go back to the Eeschema schematic editor. If you didn’t save it in Cvpcb save it
now by clicking on File → Save. Create the netlist again. Your netlist file has now been updated with all the
footprints. Note that if you are missing the footprint of any device, you will need to make your own footprints.
This will be explained in a later section of this document.

56. Przełącz się na menadżera projektu.

57. Plik z listą sieci określa wszystkie komponenty oraz ich poszczególne połączenia z innymi komponentami. Lista
sieci to w rzeczywistości zwykły tekst, który możesz łatwo podglądać, edytować lub drukować.

Notatka
Pliki biblioteczne (*.lib) to także pliki tekstowe, które również można łatwo edytować jak i wydrukować.

58. To create a Bill Of Materials (BOM), go to the Eeschema schematic editor and click on the Generate bill of

materials icon on the top toolbar. By default there is no plugin active. You add one, by clicking on Add
Plugin button. Select the *.xsl file you want to use, in this case, we select bom2csv.xsl.
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Notatka
Linux:
Jeśli brak xlstproc, można go pobrać i zainstalować poleceniem:

sudo apt-get install xsltproc

dla dystrybucji opartej o Debiana jak Ubuntu, lub

sudo yum install xsltproc

dla dystrybucji opartej na RedHat. Jeśli twoja dystrybucja nie jest oparta na tych dwóch bazach, użyj dostępnego
menadżera pakietów by zainstalować pakiet xsltproc.
pliki xsl są umieszczone w: /usr/lib/kicad/plugins/.
Apple OS X:
Jeśli xlstproc nie występuje w systemie, można zainstalować Apple Xcode z witryny Apple lub pobrać i zainstalować
poprzez polecenie:

brew install libxslt

pliki xsl są umieszczone w: /Library/Application Support/kicad/plugins/.
Windows:
xsltproc.exe oraz dołączone pliki xsl powinny być umieszczone w ＜ Folder instalacji programu KiCad ＞\bin oraz
＜ Folder instalacji programu KiCad ＞\bin\scripting\plugins .
Wszystkie platformy:
Można pobrać najnowszy plik bom2csv.xsl spod adresu:
https://raw.githubusercontent.com/KiCad/kicad-source-mirror/master/eeschema/plugins/xsl_scripts/-
bom2csv.xsl

KiCad automatycznie wygeneruje odpowiednią linię poleceń, przykładowo:

xsltproc -o "%O" "/home/<user>/kicad/eeschema/plugins/bom2csv.xsl" "%I"

Mógłbyś chcieć dodać rozszerzenie, zatem zmień tą linię poleceń w ten sposób:

xsltproc -o "%O.csv" "/home/<user>/kicad/eeschema/plugins/bom2csv.xsl" "%I"

Naciśnij przycisk Pomoc by uzyskać pomoc.

59. Teraz naciśnij Generuj. Plik (ta sama nazwa jaką ma projekt) jest umieszczona w folderze projektu. Otwórz
plik *.csv za pomocą arkusza kalkulacyjnego. Pojawi się okno importu, w którym z reguły wystarczy kliknąć
OK.

Jesteś już gotów by przejść do części poświęconej tworzeniu płytek PCB, która znajduje się w następnej sekcji. Jed-
nakże, przedtem spójrzmy szybko na możliwości jakie dają magistrale w łączeniu wyprowadzeń.

4.2 Magistrale w programie KiCad

Czasami zachodzi potrzeba podłączenia kilku kolejnych wyprowadzeń komponentu A z kolejnymi wyprowadzeniami
komponentu B. W tym przypadku masz dwie opcje: metoda etykietowania, którą już poznaliśmy lub użycie połączeń

https://raw.githubusercontent.com/KiCad/kicad-source-mirror/master/eeschema/plugins/xsl_scripts/bom2csv.xsl
https://raw.githubusercontent.com/KiCad/kicad-source-mirror/master/eeschema/plugins/xsl_scripts/bom2csv.xsl
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w formie magistrali. Zobaczmy jak je zrobić.

1. Przypuśćmy, że masz trzy 4-pinowe złącza, które chcesz połączyć razem pin do pinu. Użyj możliwości dodawania
etykiet (wciśnij klawisz [l]) by dodać etykietę na wyprowadzeniu numer 4 komponentu P4. Nazwij tą etykietę
a1. Teraz wciśnij klawisz [Insert] by ponowić automatycznie tą samą akcję na pinie poniżej (PIN 3). Zauważ, że
etykieta została automatycznie przemianowana na a2.

2. Naciśnij klawisz [Insert] jeszcze dwukrotnie. Klawisz ten odpowiada za polecenie Powtórz ostatnie polecenie i
jest to nieskończenie przydatne polecenie, które może sprawić by twoje życie było łatwiejsze.

3. Powtórz tą samą akcję nadawania etykiet na dwóch następnych złączach CONN_2 i CONN_3, i gotowe. Jeśli
będziesz działał dalej i stworzysz PCB zobaczysz, że te trzy złącza są połączone ze sobą. Rysunek 2 ukazuje
rezultat tego co opisaliśmy. Ze względów estetycznych jest także możliwe dodanie serii Wejść do magistrali

używając ikony oraz samej magistrali używając ikony , tak jak pokazuje Rysunek 3. Pamiętaj jednak,
że nie będzie to miało żadnego wpływu na PCB.

4. Powinniśmy nadmienić, że krótkie odcinki połączeń podłączonych do wyprowadzeń na Rysunku 2 nie są wcale
konieczne. Faktycznie, etykiety mogłyby zostać przypięte bezpośrednio do wyprowadzeń.

5. Pójdźmy o krok dalej i przypuśćmy, że masz czwarte złącze nazwane CONN_4 i, z jakiegoś powodu, jego etykiety
mają być nieco inne (b1, b2, b3, b4). Teraz chcemy połączyć Magistralę A z Magistralą B pin do pinu. Chcąc to
zrobić bez użycia etykiet (co również jest możliwe) musimy zamiast nich użyć etykiet na magistralach, po jednej
na każdej z magistral.

6. Połącz i dodaj etykiety do CONN_4 używając metody stawiania etykiet wyjaśnionej wcześniej. Nazwij wyprowadzenia

b1, b2, b3 i b4. Połącz piny z magistralą za pomocą Wejść do magistrali używając ikony oraz magistrali

używając ikony . Zobacz Rysunek 4.

7. Umieść etykietę (naciśnij klawisz [l]) na magistrali połączonej z CONN_4 i nazwij ją b[1..4].

8. Put a label (press [l]) on the previous bus and name it a[1..4].

9. Co teraz możemy zrobić? Połączymy magistralę a[1..4] z magistralą b[1..4] używając narzędzia do rysowania

magistral .

10. Łącząc te dwie magistrale razem, wyprowadzenie a1 będzie automatycznie połączone z wyprowadzeniem b1, a2
będzie połączone z b2 i tak dalej. Rysunek 4 pokazuje jak to powinno prawidłowo wyglądać.

Notatka
Polecenie Powtórz ostatnie polecenie dostępne z klawisza [Insert] może być z powodzeniem używane do powtórzenia
powtarzalnych poleceń. Przykładowo, krótkie odcinki połączeń łączące wszystkie piny na Rysunku 2, Rysunku 3
oraz Rysunku 4 zostały narysowane w ten sposób.

11. Polecenie Powtórz ostatnie polecenie dostępne z klawisza [Insert] może być rozlegle stosowane przy umieszczaniu

wielu Wejść do magistrali dostępnych spod ikony .
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Rozdział 5

Trasowanie połączeń w obwodach drukowanych

Już czas by użyć pliku z listą sieci jaką wygenerowałeś by rozpocząć trasowanie ścieżek na PCB. Tym zajmuje się
narzędzie Pcbnew.

5.1 Używanie programu Pcbnew

1. From the KiCad project manager, click on the Pcb layout editor icon . The Pcbnew window will open.
If you get an error message saying that a *.kicad_pcb file does not exist and asks if you want to create it, just
click Yes.

2. Begin by entering some schematic information. Click on the Page settings icon on the top toolbar. Set the
appropriate paper size (A4,8.5x11 etc.) and title as Tutorial1.

3. It is a good idea to start by setting the clearance and the minimum track width to those required by your
PCB manufacturer. In general you can set the clearance to 0.25 and the minimum track width to 0.25. Click on
the Setup → Design Rules menu. If it does not show already, click on the Net Classes Editor tab. Change the
Clearance field at the top of the window to 0.25 and the Track Width field to 0.25 as shown below. Measurements
here are in mm.
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4. Click on the Global Design Rules tab and set Minimum track width to 0.25. Click the OK button to commit
your changes and close the Design Rules Editor window.

5. Now we will import the netlist file. Click on the Read netlist icon on the top toolbar. The netlist file
tutorial1.net should be selected in the Netlist file field if it was created from Eeschema. Click on Read Current
Netlist. Then click the Close button.

6. All components should now be visible. They are selected and follow the mouse cursor.

7. Move the components to the middle of the board. If necessary you can zoom in and out while you move the
components. Click the left mouse button.

8. All components are connected via a thin group of wires called ratsnest. Make sure that the Show/hide board

ratsnest button is pressed. In this way you can see the ratsnest linking all components.

9. You can move each component by hovering over it and pressing [m]. Click where you want to place them.
Alternatively you can select a component by clicking on it and then drag it. Press [r] to rotate a component.
Move all components around until you minimise the number of wire crossovers.
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10. Note how one pin of the 100 ohm resistor is connected to pin 6 of the PIC component. This is the result of
the labelling method used to connect pins. Labels are often preferred to actual wires because they make the
schematic much less messy.

11. Now we will define the edge of the PCB. Select the Edge.Cuts layer from the drop-down menu in the top toolbar.

Click on the Add graphic lines icon on the right toolbar. Trace around the edge of the board, clicking at
each corner, and remember to leave a small gap between the edge of the green and the edge of the PCB.

12. Następnym krokiem jaki zrobimy będzie wytrasowanie wszystkich połączeń za wyjątkiem GND. W rzeczywis-
tości, połączymy sieć GND używając do tego celu stref miedzi umieszczonego na dolnej warstwie miedzi (zwanej
B.Cu) naszej płytki.

13. Teraz musimy wybrać na jakiej warstwie będziemy operować. Wybierz F.Cu (PgUp) z rozwijanej listy na górnym
pasku narzędzi. Jest to górna warstwa miedzi płytki, tzn. ta na której normalnie są elementy.
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14. If you decide, for instance, to do a 4 layer PCB instead, go to Setup → Layers Setup and change Copper
Layers to 4. In the Layers table you can name layers and decide what they can be used for. Notice that there
are very useful presets that can be selected via the Preset Layer Groupings menu.

15. Click on the Route tracks icon on the right toolbar. Click on pin 1 of J1 and run a track to pad R2.
Double-click to set the point where the track will end. The width of this track will be the default 0.250 mm.
You can change the track width from the drop-down menu in the top toolbar. Mind that by default you have
only one track width available.
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16. If you would like to add more track widths go to: Setup → Design Rules → Global Design Rules tab and
at the bottom right of this window add any other width you would like to have available. You can then choose
the widths of the track from the drop-down menu while you lay out your board. See the example below (inches).

17. Alternatively, you can add a Net Class in which you specify a set of options. Go to Setup → Design Rules
→ Net Classes Editor and add a new class called power. Change the track width from 8 mil (indicated as
0.0080) to 24 mil (indicated as 0.0240). Next, add everything but ground to the power class (select default at
left and power at right and use the arrows).

18. If you want to change the grid size, Right click → Grid. Be sure to select the appropriate grid size before or
after laying down the components and connecting them together with tracks.

19. Ponów operację dodawania ścieżek, aż wszystkie połączenia zostaną zrealizowane, oprócz pinu numer 3 elementu
J1. Twoja płytka powinna wyglądać mniej więcej tak jak na poniższym przykładzie.
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20. Let’s now run a track on the other copper side of the PCB. Select B.Cu in the drop-down menu on the top

toolbar. Click on the Route tracks icon . Draw a track between pin 3 of J1 and pin 8 of U1. This is actually
not necessary since we could do this with the ground plane. Notice how the colour of the track has changed.

21. Trasowanie połączeń pomiędzy pinami A i B ze zmianą warstwy. Podczas trasowania ścieżki można
zmienić warstwę wstawiając przelotkę. W czasie gdy prowadzisz ścieżkę na górnej warstwie miedzi, kliknij
prawym klawiszem i wybierz Dodaj przelotkę lub po prostu naciśnij klawisz [v]. To spowoduje przeniesienie
dalszych segmentów na warstwę dolną gdzie ścieżka zostanie dokończona.
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22. When you want to inspect a particular connection you can click on the Highlight net icon on the right
toolbar. Click on pin 3 of J1. The track itself and all pads connected to it should become highlighted.

23. Now we will make a ground plane that will be connected to all GND pins. Click on the Add filled zones icon

on the right toolbar. We are going to trace a rectangle around the board, so click where you want one of
the corners to be. In the dialogue that appears, set Default pad connection to Thermal relief and Outline slope
to H,V and 45 deg only and click OK.

24. Trace around the outline of the board by clicking each corner in rotation. Finish your rectangle by clicking the
first corner second time. Right click inside the area you have just traced. Click on Zones→’Fill or Refill All
Zones’. The board should fill in with green and look something like this:
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25. Run the design rules checker by clicking on the Perform design rules check icon on the top toolbar. Click
on Start DRC. There should be no errors. Click on List Unconnected. There should be no unconnected items.
Click OK to close the DRC Control dialogue.

26. Zapisz swój plik PCB klikając na Plik → Zapisz. By zobaczyć swoją płytkę w 3D, kliknij na Widok → Widok
3D.
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27. Możesz przeciągnąć myszą wokół by obracać płytką.

28. Twoja płytka jest już kompletna. By wysłać ją do producenta będziesz musiał wygenerować pliki Gerber.

5.2 Generowanie plików Gerber

Jeśli twoje PCB jest kompletne, możesz wygenerować pliki Gerber dla każdej z warstw płytki i wysłać je do wybranego
producenta PCB, który na ich podstawie stworzy dla ciebie fizyczną płytkę drukowaną.

1. From KiCad, open the Pcbnew board editor.

2. Click on File → Plot. Select Gerber as the Plot format and select the folder in which to put all Gerber files.
Proceed by clicking on the Plot button.

3. By wygenerować plik wierceń, z Pcbnew wybierz ponownie opcję Plik → Rysuj. Domyślne ustawienia powinny
być dobre.

4. To są warstwy jakie potrzebujesz do wykonania typowej płytki dwustronnej:
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Layer KiCad Layer Name Default Gerber
Extension

”Use Protel filename
extensions”is enabled

Bottom Layer B.Cu .GBR .GBL
Top Layer F.Cu .GBR .GTL
Top Overlay F.SilkS .GBR .GTO
Bottom Solder Resist B.Mask .GBR .GBS
Top Solder Resist F.Mask .GBR .GTS
Edges Edge.Cuts .GBR .GM1

5.3 Używanie programu GerbView

1. To view all your Gerber files go to the KiCad project manager and click on the GerbView icon. On the drop-down
menu or in the Layers manager select Graphic layer 1. Click on File → Open Gerber file(s) or click on the

icon . Select and open all generated Gerber files. Note how they all get displayed one on top of the other.

2. Open the drill files with File → Open Excellon Drill File(s).

3. Use the Layers manager on the right to select/deselect which layer to show. Carefully inspect each layer before
sending them for production.

4. The view works similarly to Pcbnew. Right click inside the view and click Grid to change the grid.

5.4 Automatyczne prowadzenie ścieżek z wykorzystaniem FreeRouter-a

Routing a board by hand is quick and fun, however, for a board with lots of components you might want to use an
autorouter. Remember that you should first route critical traces by hand and then set the autorouter to do the boring
bits. Its work will only account for the unrouted traces. The autorouter we will use here is FreeRouting.

Notatka
FreeRouting is an open source java application. Currently FreeRouting exists in several more or less identical copies which
you can find by doing an internet search for ”freerouting”. It may be found in source only form or as a precompiled java
package.

1. From Pcbnew click on File → Export → Specctra DSN and save the file locally. Launch FreeRouter and
click on the Open Your Own Design button, browse for the dsn file and load it.

2. FreeRouter posiada pewne cechy których KiCad w tej chwili nie posiada, oba przy manualnym i automatycznym
trasowaniu ścieżek. FreeRouter działa za pomocą dwóch głównych kroków: pierwszy, trasuje on ścieżki na płytce
first, a następnie je optymalizuje. Pełna optymalizacja może zabrać sporo czasu, jednak możesz ją zatrzymać w
każdej chwili.

3. Możesz rozpocząć automatyczne trasowanie ścieżek klikając na przycisk Autorouter na górnym pasku. Dolny
pasek przedstawia informacje o przebiegu trasowania. Jeśli licznik Pass zbliży się do wartości 30, twoja płytka
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prawdopodobnie nie może zostać wytrasowana z pomocą tego routera. Rozszerz nieco przestrzeń pomiędzy
komponentami lub obróć niektóre z nich i spróbuj ponownie. Celem rotacji i zmiany pozycji elementów jest
zmniejszenie ilości krzyżujących się połączeń.

4. Kliknięcie lewym klawiszem myszy zatrzymuje proces automatycznego trasowania i automatycznie rozpoczyna
proces optymalizacji połączeń. Ponowne kliknięcie zatrzyma proces optymalizacji. Jeśli naprawdę nie masz
zamiaru przerwać jednego z tych dwóch procesów, lepiej zaczekaj aby FreeRouter zakończył swoją pracę.

5. Kliknij na File → Export Specctra Session File oraz zapisz plik płytki z rozszerzeniem .ses. Nie będzie
trzeba zapisywać pliku reguł FreeRouter.

6. Back to Pcbnew. You can import your freshly routed board by clicking on File → Import → Spectra Session
and selecting your .ses file.

If there is any routed trace that you do not like, you can delete it and re-route it again, using [Delete] and the routing

tool, which is the Route tracks icon on the right toolbar.
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Rozdział 6

Renumeracja elementów w programie KiCad

Po skompletowaniu już schematu elektronicznego, przypisaniu footprintów, wytrasowaniu ścieżek i wygenerowaniu
plików Gerber, jesteś gotów, by wysłać wszystko do producenta PCB tak, aby płytka mogła stać się rzeczywistością.

Często ta liniowość procesu pracy nad płytką okazuje się nie być taka jednokierunkowa. Na przykład, gdy musisz
zmodyfikować/rozszerzyć płytkę, dla której ty lub inne osoby już wykonały cały proces projektowy, może zajść potrzeba
przeniesienia niektórych elementów, zastąpić je innymi, dokonać zmiany footprintów lub jeszcze innych poprawek.
Podczas procesu modyfikacji z pewnością nie chciałbyś ponownie trasować całej płytki od początku. Zamiast tego,
powinieneś zrobić to w ten sposób:

1. Przypuśćmy, że hipotetycznie chcesz zamienić złącze CON1 przez CON2.

2. Masz już w pełni stworzony schemat jak i płytkę.

3. Z menedżera projektu KiCad, uruchom Eeschema, dokonaj swoich modyfikacji usuwając złącze CON1 i dodając

CON2. Zapisz swój projekt schematu z pomocą ikony i kliknij w ikonę Utwórz listę sieci na górnym
pasku narzędzi.

4. Kliknij na Lista sieci następnie na Zapisz. Zapisz pod domyślną nazwą, nadpisując starą listę sieci.

5. Teraz przypiszemy footprint dla CON2. Kliknij w Uruchom CvPcb na górnym pasku narzędzi. Przypisz
footprint do nowego elementu CON2. Reszta komponentów nadal posiada poprzednio im przypisane footprinty.
Zamknij CvPcb.

6. Wróć do edytora schematów, zapisz projekt klikając na Plik → Zapisz cały projekt schematu. Zamknij
edytor schematów.

7. Z menedżera projektu, kliknij w ikonę Pcbnew. Otworzy się okno Pcbnew.

8. Stara, już wytrasowana płytka powinna się otworzyć automatycznie. Zaimportujmy nową listę sieci. Kliknij na

Wczytaj listę sieci na górnym pasku narzędzi.

9. Kliknij na klawisz Przeglądaj listy sieci, wybierz plik z listą sieci w oknie dialogowym wyboru pliku oraz kliknij
na Wczytaj bieżącą listę sieci. Następnie kliknij klawisz Zamknij.
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10. W tym punkcie powinieneś już zobaczyć obwód drukowany z poprzednio wytyczonymi ścieżkami. W lewym
górnym rogu powinieneś zobaczyć wszystkie komponenty jakie nie zostały jak dotąd w pełni umieszczone na
płytce, w twoim przypadku CON2. Wybierz CON2 za pomocą myszy. Przesuń komponent na środek płytki.

11. Umieść CON2 we właściwym miejscu i pociągnij ścieżki. Po tych operacjach, zapisz projekt i wygeneruj pliki
Gerber tak jak zwykle.

Proces opisany tutaj może być łatwo powtórzony tyle razy, ile trzeba. Oprócz metody opisanej powyżej, jest również
inna metoda znana jako numeracja wsteczna. Metoda ta pozwala na dokonywanie zmian w wytrasowanym już PCB
w Pcbnew i przeniesienia tych zmian do schematu i plików z listą sieci. Metoda numeracji wstecznej, jednak nie jest
tak użyteczna i dlatego nie jest tutaj opisana.
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Rozdział 7

Make schematic symbols in KiCad

Sometimes a symbol that you want to place on your schematic is not in a KiCad library. This is quite normal and
there is no reason to worry. In this section we will see how a new schematic symbol can be quickly created with KiCad.
Nevertheless, remember that you can always find KiCad components on the Internet.

In KiCad, a symbol is a piece of text that starts with DEF and ends with ENDDEF. One or more symbols are normally
placed in a library file with the extension .lib. If you want to add symbols to a library file you can just use the cut
and paste commands of a text editor.

7.1 Używanie Edytora bibliotek

1. Możemy użyć Edytora bibliotek (cześć programu Eeschema) do tworzenia nowych komponentów. W naszym
folderze projektu tutorial1 stwórzmy folder nazwany library. Wewnątrz niego umieścimy nasz nowy plik biblioteki
myLib.lib jak stworzymy nasz nowy komponent.

2. Now we can start creating our new component. From KiCad, start Eeschema, click on the Library Editor icon

and then click on the New component icon . The Component Properties window will appear. Name
the new component MYCONN3, set the Default reference designator as J, and the Number of units per package
as 1. Click OK. If the warning appears just click yes. At this point the component is only made of its labels.

Let’s add some pins. Click on the Add Pins icon on the right toolbar. To place the pin, left click in the
centre of the part editor sheet just below the MYCONN3 label.

3. In the Pin Properties window that appears, set the pin name to VCC, set the pin number to 1, and the Electrical
type to Power input then click OK.
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4. Umieść pin klikając w miejscu gdzie chciałbyś aby się pojawił, mniej więcej na prawo pod etykietą MYCONN3.

5. Powtórz kroki z tworzeniem pinu ponownie, tym razem wpisując w pole Nazwa pinu nazwę INPUT, Numer pinu
na 2, a Typ elektryczny na Pasywny.

6. Powtórz ostatni raz kroki z tworzeniem pinu, tym razem wypełniając pola Nazwa pinu jako GND, Numer pinu
na 3, a Typ elektryczny jako Pasywny. Ustaw piny tak by były jeden nad drugim. Etykieta MYCONN3 powinna
znaleźć się w centrum (gdzie krzyżują się dwie niebieskie linie).

7. Następnie, narysuj kontur symbolu. Kliknij w ikonę Dodaj prostokąt (grafika) . Chcielibyśmy by został
narysowany kwadrat obok pinów, tak jak pokazuje to rysunek. By to zrobić, kliknij w miejscu gdzie chciałbyś
umieścić lewy, górny narożnik. Kliknij ponownie w miejscu gdzie chciałbyś umieścić prawy dolny narożnik.
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8. Jeśli prostokąt miałby być wypełniony na żółto, należy ustawić kolor Żółty 4 wUstawienia→Kolory, następnie
umieszczając kursor nad prostokątem wcisnąć [e] i w oknie dialogowym zaznaczyć Wypełnienie drugoplanowe.

9. Zapiszmy komponent w naszej bibliotece myLib.lib. Kliknij w ikonę Zapisz bieżący symbol w nowej bibliotece

, przejdź do folderu tutorial1/library/ i zapisz nowy plik biblioteki pod nazwą myLib.lib.

10. Idź do Ustawienia → Biblioteka i dodaj zarówno tutorial1/library/ w Bieżąca lista przeglądanych ścieżek jak
i myLib.lib w Pliki bibliotek symboli.

11. Kliknij w ikonę ’Wybierz bibliotekę roboczą’ . W oknie Wybór biblioteki kliknij na myLib i kliknij OK.
Zauważ, że nagłówek okna wskazuje jaka biblioteka jest aktualnie w użyciu, powinien on teraz zawierać myLib.

12. Kliknij w ikonę Zaktualizuj symbol w bieżącej bibliotece na górnym pasku narzędzi. Zapisz wszystkie zmiany

klikając w ikonę Zapisz bieżącą bibliotekę na dysk na górnym pasku narzędzi. Kliknij na Tak w oknie z
komunikatem potwierdzenia jakie się pojawi. Nowy symbol jest zrobiony i dostępny w bibliotece, której nazwę
wskazuje pasek tytułowy.

13. Możesz teraz zamknąć okno Edytora bibliotek. Tym samym wrócisz do okna edytora schematu. Nowy komponent
będzie dostępny dla ciebie w bibliotece myLib.

14. Możesz udostępnić dla danego projektu każdy plik biblioteki, np. file.lib dodając go do przeglądanych ścieżek.
Z poziomu Eeschema, idź do Ustawienia → Biblioteka i dodaj zarówno ścieżkę do niego w Bieżąca lista
przeglądanych ścieżek, jak i sam plik file.lib w Plik bibliotek symboli.
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7.2 Eksportowanie, importowanie oraz modyfikacje składników bibliotek

Zamiast tworzyć symbol w bibliotece od zera, czasem łatwiej jest zacząć od istniejącego symbolu, modyfikując go.
W tej sekcji zobaczymy jak wyeksportować komponent ze standardowej biblioteki device do naszej własnej biblioteki
myOwnLib.lib a następnie go zmodyfikujemy.

1. Z menedżera uruchom Eeschema, kliknij w ikonę Edytor bibliotek , kliknij w ikonęWybierz bibliotekę roboczą’

oraz wybierz bibliotekę ’device. Kliknij w ikonę Wczytaj symbol z bieżącej biblioteki w celu edycji i
zaimportuj symbol RELAY_2RT.

2. Kliknij w ikonę Eksportuj symbol , przejdź do folderu library/ oraz zapisz nową bibliotekę pod nazwą
myOwnLib.lib.

3. Możesz stworzyć ten komponent i dołączyć całą bibliotekęmyOwnLib.lib do dostępnych bibliotek poprzez dodanie
jej do ścieżek przeszukiwań bibliotek. Z poziomu Eeschema, idź do Ustawienia → Biblioteka i dodaj zarówno
ścieżkę do library/ w Bieżąca lista przeglądanych ścieżek oraz myOwnLib.lib w Plik bibliotek symboli. Po czym
zamknij okno.

4. Kliknij w ikonę ’Wybierz bibliotekę roboczą’ . W oknie Wybór biblioteki kliknij na myOwnLib oraz na OK.
Zauważ, że pasek tytułowy okna zmienił się i wskazuje na aktywną bibliotekę myOwnLib.

5. Kliknij w ikonę Wczytaj symbol z bieżącej biblioteki w celu edycji i zaimportuj RELAY_2RT.

6. Możesz teraz zmodyfikować ten symbol jak chcesz. Najedź na etykietę RELAY_2RT, wciśnij klawisz [e] i zmień
nazwę na MY_RELAY_2RT.

7. Kliknij w ikonę Zaktualizuj symbol w bieżącej bibliotece na górnym pasku narzędzi. Zapisz wszystkie zmiany

klikając w ikonę Zapisz bieżącą bibliotekę na dysk na górnym pasku narzędzi.

7.3 Tworzenie symboli za pomocą Quicklib

Ten rozdział prezentuje alternatywny sposób tworzenia komponentu MYCONN3 (zobacz MYCONN3 powyżej) uży-
wając do tego celu narzędzia on-line quicklib.

1. Przejdź na stronę quicklib: http://kicad.rohrbacher.net/quicklib.php

2. Wypełnij formularz zgodnie z następującymi informacjami: Component name: MYCONN3 Reference Prefix: J
Pin Layout Style: SIL Pin Count, N: 3

3. Kliknij w ikonę Assign Pins. Wypełnij pola następującymi informacjami: Pin 1: VCC Pin 2: input Pin 3: GND.
Type: Passive dla wszystkich trzech pinów.

4. Kliknij w ikonę Preview it i, jeśli jesteś usatysfakcjonowany, kliknij na Build Library Component. Pobierz plik i
zmień jego nazwę na tutorial1/library/myQuickLib.lib. To wszystko!

http://kicad.rohrbacher.net/quicklib.php
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5. Zobacz jak wygląda symbol w programie KiCad. Z menedżera projektu uruchom Eeschema, kliknij w ikonę Edy-

tor bibliotek , kliknij w ikonę Importuj symbol, przejdź do tutorial1/library/ i wybierz myQuickLib.lib.

6. Możesz dodać ten komponent jak i bibliotekę do dostępnych bibliotek. Z poziomu Eeschema, idź do Ustawienia
→ Biblioteka i dodaj zarówno ścieżkę do library/ w Bieżąca lista przeglądanych ścieżek oraz myQuickLib.lib w
Plik bibliotek symboli.

Jak pewnie zgadłeś, ta metoda tworzenia symboli bibliotecznych może być bardzo efektywna, przy tworzeniu symboli,
które zawierają w sobie dużą ilość wyprowadzeń. Ale jest też inny sposób.

7.4 Tworzenie symboli z dużą ilością wyprowadzeń

W sekcji zwanej Tworzenie symboli za pomocą quicklib poznaliśmy jak tworzyć symbole używając do tego celu narzędzia
quicklib opartego o stronę Web. Jednak, czasami możesz doświadczyć sytuacji, że będziesz potrzebował symbolu,
który zawierał będzie dużą ilość wyprowadzeń (np. paręset wyprowadzeń). W programie KiCad nie jest to aż tak
skomplikowane zadanie.

1. Przypuśćmy, że chciałbyś utworzyć symbol, który posiadał będzie 50 wyprowadzeń. Praktycznie stosowaną
metodą jest podzielenie takiego elementu na mniejsze części, dla przykładu na dwie zawierające po 25 wyprowadzeń.
Taka reprezentacja symbolu pozwala na łatwiejsze łączenie wyprowadzeń.

2. Najlepszym sposobem jest użycie quicklib gdzie wygenerujemy dwa symbole po 25 pinów w każdym, i zmienimy
numerację pinów za pomocą skryptu języka Python i na koniec połączymy te dwa symbole w jeden korzystając
z metody kopiuj-wklej w jeden komponent zawarty pomiędzy DEF a ENDDEF.

3. Przykład takiego prostego skryptu języka Python znajdziesz poniżej. Może on być użyty w połączeniu z plikami
in.txt oraz out.txt gdzie zamienimy linie zawierające: X PIN1 1 -750 600 300 R 50 50 1 1 I na X PIN26 26
-750 600 300 R 50 50 1 1 I, dla wszystkich linii w pliku in.txt.
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Prosty skrypt

#!/usr/bin/env python
''' simple script to manipulate KiCad component pins numbering'''
import sys, re
try:

fin=open(sys.argv[1],'r')
fout=open(sys.argv[2],'w')

except:
print "oh, wrong use of this app, try:", sys.argv[0], "in.txt out.txt"
sys.exit()

for ln in fin.readlines():
obj=re.search("(X PIN)(\d*)(\s)(\d*)(\s.*)",ln)

if obj:
num = int(obj.group(2))+25
ln=obj.group(1) + str(num) + obj.group(3) + str(num) + obj.group(5) +'\n'
fout.write(ln)

fin.close(); fout.close()
#
# for more info about regular expression syntax and KiCad component generation:
# http://gskinner.com/RegExr/
# http://kicad.rohrbacher.net/quicklib.php

1. Podczas łączenia dwóch symboli w jeden, będzie konieczne użycie Edytora Bibliotek programu Eeschema by
przenieść pierwszy symbol, tak aby drugi z symboli go nie przykrył. Poniżej możesz zobaczyć finalny plik .lib i
jego reprezentację w Eeschema.

Zawartość pliku *.lib

EESchema -LIBRARY Version 2.3
#encoding utf-8
# COMP
DEF COMP U 0 40 Y Y 1 F N
F0 "U" -1800 -100 50 H V C CNN
F1 "COMP" -1800 100 50 H V C CNN
DRAW
S -2250 -800 -1350 800 0 0 0 N
S -450 -800 450 800 0 0 0 N
X PIN1 1 -2550 600 300 R 50 50 1 1 I

...

X PIN49 49 750 -500 300 L 50 50 1 1 I
ENDDRAW
ENDDEF
#End Library



Wprowadzenie do programu KiCad 44 / 50

1. Skrypt języka Python zaprezentowany tutaj jest bardzo potężnym narzędziem przy manipulacji numeracją
wyprowadzeń i ich opisów. Pamiętaj jednak, że cała moc tego skryptu tkwi tylko w części operującej na Wyraże-
niach Regularnych: http://gskinner.com/RegExr/
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Rozdział 8

Tworzenie footprint-ów

Unlike other EDA software tools, which have one type of library that contains both the schematic symbol and the
footprint variations, KiCad .lib files contain schematic symbols and .kicad_mod files contain footprints. Cvpcb is used
to map footprints to symbols.

Zarówno pliki .lib, jak i pliki .kicad_mod to pliki tekstowe, zawierające wszystkie od jednej do kilku części.

Istnieje obszerna biblioteka modułów programu KiCad, jednak od czasu do czasu może się okazać, że moduł jaki
potrzebujesz nie znajduje się w bibliotekach KiCad-a. Oto krótki przewodnik procesu tworzenia nowego modułu w
programie KiCad:

8.1 Używanie Edytora footprintów

1. Z menedżera projektu KiCad uruchom Pcbnew. Kliknij w ikonę Otwórz edytor modułów na górnym pasku
narzędzi. Spowoduje to otwarcie Edytora Footprintów.

2. We are going to save the new footprint MYCONN3 in the new footprint library myfootprint. Create a new folder
myfootprint.pretty in the tutorial1/ project folder. Click on the Preferences → Footprint Libraries Man-
ager and press Append Library button. In the table, enter ”myfootprint ↪as Nickname, enter ”${KIPRJMOD}/
myfootprint.pretty ↪as Library Path and enter ”KiCad ↪as Plugin Type. Press OK to close the PCB Library Tables

window. Click on the Select active library icon on the top toolbar. Select the myfootprint library.

3. Kliknij w ikonę Nowy footprint na górnym pasku narzędzi. Wpisz MYCONN3 jako Nazwa footprintu.
W środku pola roboczego pojawi się etykieta MYCONN3. Pod nią możesz zobaczyć drugą etykietę REF*.
Kliknij prawym klawiszem myszy na MYCONN3 i przesuń etykietę powyżej REF*. Kliknij prawym klawiszem
na REF*_, wybierz Edytuj tekst modułu i zmień go na SMD. Ustaw wartość _Pokazuj na Niewidoczny.

4. Wybierz ikonę Dodaj pola lutownicze na prawym pasku narzędzi. Kliknij w obszarze roboczym by umieścić
tam pole lutownicze. Kliknij prawym klawiszem na nowym polu i kliknij Edytuj pole. Możesz też użyć klawisza
[e].
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5. Ustaw Numer pola na 1, Kształt pola na Prostokąt, Typ pola na SMD, Rozmiar X na 0.4, oraz Rozmiar Y na
0.8. Kliknij OK. Kliknij na Dodaj pola lutownicze ponownie i wstaw jeszcze dwa pola lutownicze.

6. Jeśli chcesz zmienić gęstość siatki, Prawo-klik → Wybór siatki. Upewnij się, że wybrałeś odpowiednią gęstość
siatki przed tworzeniem dalszych elementów modułu.

7. Przesuń etykietę MYCONN3 oraz SMD poza pola lutownicze, tak aby znalazły mniej więcej w miejscach
pokazanych na następnym obrazku.

8. Gdy wstawiamy pola lutownicze często jest konieczne korzystanie z pomiaru odległości względnej. Umieść
kursor gdzie chciałbyś umieścić punkt początkowy (0, 0) względnego układu współrzędnych i naciśnij klawisz
Spacja. Jeśli poruszasz myszą, zauważysz, że współrzędne relatywne pokazywane na pasku statusu będą odnosić
się do ustalonego teraz punktu zerowego. Możesz przenosić ten punkt zerowy za każdym razem jak będziesz
potrzebował określić dystans od jakiegoś wybranego punktu.

9. Teraz dodamy obrys modułu. Kliknij w ikonę Dodaj linię lub wielokąt (grafika) na prawym pasku narzędzi.
Narysuj obrys wokół pól lutowniczych.

10. Kliknij w ikonę Zapisz moduł w aktywnej bibliotece na górnym pasku narzędzi i użyj domyślnej nazwy
MYCONN3.
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Rozdział 9

Uwagi na temat przenoszenia plików projek-
tów wykonanych w programie KiCad

Jakie pliki musisz wysłać do kogoś, by mógł on w pełni załadować i użyć twojego projektu?

Jeśli będziesz musiał się z kimś podzielić swoim projektem, ważne jest by plik ze schematem .sch, plik z płytką
.kicad_pcb, plik projektu .pro oraz plik z listą sieci .net, wysłać razem z bibliotekami symboli .lib oraz bibliotekami
footprintów .kicad_mod. Tylko w ten sposób inne osoby będą miały wolną rękę w modyfikacji schematu lub obwodu
drukowanego.

Dla schematu, będą potrzebne pliki bibliotek .lib które zawierają w sobie definicje symboli. Te biblioteki muszą zostać
załadowane poprzez odpowiednie ustawienia w programie Eeschema. Z drugiej strony, footprinty mogą być zapisane
w plikach PCB (pliki .kicad_pcb). Możesz wysłać komuś plik .kicad_pcb i nic poza tym, a on dalej będzie miał
możliwość oglądania lub edycji płytki. Jednak, jeśli chciałby on załadować moduły z listy sieci, biblioteki footprintów
(pliki .kicad_mod) muszą być obecne i poprawnie załadowane przez ustawienia programu Pcbnew, tak jak w przypadku
schematu. Niezbędne są one także przy przypisywaniu symbolom footprintów za pomocą programu CvPcb.

Jeśli ktoś prześle ci plik .kicad_pcb z modułami które chciałbyś użyć na innej płytce, możesz otworzyć edytor foot-
printów, załadować footprint z bieżącej płytki, oraz zapisać lub wyeksportować go do innej biblioteki. Możesz także
wyeksportować wszystkie footprinty z pliku .kicad_pcb za jednym razem, stosując polecenie Pcbnew Plik → Archi-
wizuj obudowy → Utwórz archiwum obudów, które tworzy nowy plik biblioteki .kicad_mod z wszystkimi mod-
ułami jakie znajdują się na płytce.

Na koniec, jeśli PCB jest tylko jedną rzeczą jaką chcesz przekazać, to sam plik .kicad_pcb jest wystarczający. Jednak,
jeśli chcesz dać komuś możliwość używania i modyfikowania twojego schematu, jego komponentów i PCB, jest wysoce
zalecane by zarchiwizować i wysłać następujące pliki (przykładowo) razem ze strukturą katalogów:

tutorial1/
|-- tutorial1.pro
|-- tutorial1.sch
|-- tutorial1.kicad_pcb
|-- tutorial1.net
|-- library/
| |-- myLib.lib
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| |-- myOwnLib.lib
| \-- myQuickLib.lib
|
|-- myfootprint.pretty/
| \-- MYCONN3.kicad_mod
|
\-- gerber/

|-- ...
\-- ...



Wprowadzenie do programu KiCad 49 / 50

Rozdział 10

Więcej na temat dokumentacji do programu
KiCad

Dokument ten, to szybki przegląd funkcji dostępnych w programie KiCad. W celu uzyskania szczegółowych instrukcji
należy zapoznać się z plikami pomocy, do których dostęp można uzyskać z każdego modułu KiCad EDA Suite. Klikając
na przykład w Pomoc → Podręcznik.

KiCad dostarczany jest razem z całkiem dobrym zestawem podręczników w wielu językach, dla wszystkich jego czterech
podstawowych składników.

Polskie wersje podręczników do programu KiCad są również dostarczane razem z programem KiCad.

Kurs ten jest rozpowszechniany razem z podręcznikami programu KiCad, i został przetłumaczony także na inne
języki. Wszystkie wersje tego poradnika są dystrybuowane bezpłatnie razem z wszystkimi najnowszymi wydaniami
programu KiCad. Ten poradnik, jak również pozostałe instrukcje można znaleźć w następujących katalogach, zależnie
od używanej platformy:

Przykładowo, w systemach Linux zwykle znajdują się w podanych niżej lokacjach, choć w dalszym ciągu zależy to od
dystrybucji:

/usr/share/doc/kicad/help/pl/
/usr/local/share/doc/kicad/help/pl

W systemie Windows:

<folder instalacji >/share/doc/kicad/help/pl

W systemie OS X:

/Library/Application Support/kicad/help/pl

10.1 Dokumentacja do programu KiCad w sieci Internet

Najnowsza dokumentacje do programu KiCad są dostępne w wielu językach pod następującym adresem:
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http://kicad-pcb.org/help/documentation/

http://kicad-pcb.org/help/documentation/
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